ComX Computers - since 2002 • home Tue 20 Oct, 2026View enquiry cart
Computers, laptops and PC hardware in South Africa.Computers
Laptops
Laptops, computers and computer hardware South Africa Computers, laptops and other PC hardware in South Africa.
Computers South AfricaLaptops, Notebooks and PDA South AfricaDigital camerasComputer hardware Tablets South AfricaSoftware - software titles South AfricaPrinters South Africa SpeakersGaming Brands
PC
My account  |  How to buy  |  Specials
computer salespc salescomputerscomputerscomputers
computers
 
computers
computers

SIP-T33G Yealink SIP-T33G Gigabit Colour screen Desktop IP phone

computers
R 1,165.00
inc. VAT
In Stock




Yealink SIP-T33G Gigabit Colour screen Desktop IP phone
Images are for illustrative purposes and actual product may differ.

Product resourcesProduct PDF
   

SIP-T33G

VoIP handsets phones

Yealink


SIP-T33G information and overview
Yealink SIP-T33G Gigabit Colour screen Desktop IP phone, Excludes PSU, 2.4" 320 x 240 Pixel Colour LCD Display, 2x Ethernet Ports 10/100/1000 PoE support, 4x SIP accounts, 4x Dual Colour line keys, Hall Switch, Local 5-way conferencing, 1x RJ9 (4p4c) handset Port



Specifications & more information about SIP-T33G, VoIP handsets phones manufactured by Yealink
Specifications & downloads View specification Printable PDF
Product information notice: Some specifications may describe a broader product range and may not apply to this exact model. Use the product summary above as the primary model reference. Bundled software may be trial software and can require a separate licence.

Overview:

Gigabit, colour screen desktop IP phone, excludes PSU
SIP-T33G

T33G for full Gigabit Ethernet connectivity with PoE and easy to use interface and colour LCD screen.

Yealinks new T33G desktop IP phone combines stylish design, great features and affordable cost, for the ideal business communication device.
The Yealink T33G boasts a 2.4" full colour mirror style screen with adjustable backlight. The keypad on the Yealink T33G has been updated to provide a more metallic feel, improving the user experience.

The new electronic hall switch on the Yealink T33G reduces mechanical parts and makes it more resilient to heavy use, while the scratch resistant surface means the phone stays looking pristine for longer.
The Yealink T33G offers excellent voice clarity thanks to Yealinks HD voice technology and smart noise filtering technology to reduce external interference.

With an advanced feature set and unbeatable voice quality, no office is complete without the Yealink T33G desktop IP phone.

Features:

  • 2.4" 320x240 pixel colour LCD display
  • 2 x Ethernet ports 10/100/1000 PoE support
  • 4 x SIP accounts
  • 4 x Dual colour line keys
  • Hall switch
  • Wall-mountable
  • High definition voice support

Benefits

  • High-speed Gigabit Ethernet does not bottleneck your connected device
  • Easily powered via PoE removing the need for a separate PSU
  • Vibrant colour display
  • Hall switch replaces hook switch for a more robust and elegant feel
  • New stylish design

Specifications:

©2026 Respective owners and brand holders. This table has been carefully researched and generated by ComXpert International CC (//www.comx-computers.co.za), however, errors and omissions may occur. Only references to South Africa apply. All products are sourced in South Africa from the official suppliers and the warranty is that of the local supplier. E&OE. This table and our site's content may be used on condition that this notice and link remains intact and unaltered.
Specifications
Product Code SIP-T33G
Phone Features 4 VoIP accounts
Call hold, mute, DND
One-touch speed dial, hotline
Call forward, call waiting, call transfer
Group listening, SMS, emergency call
Redial, call return, auto answer
Local 5-way conferencing
Direct IP call without SIP proxy
Ring tone selection/import/delete
Set date time manually or automatically
Dial plan
XML Browser, action URL/URI
Integrated screenshots
RTCP-XR, VQ-RTCPXR
Enhanced DSS Key
Directory Loal phonebook up to 1000 entries
Black list
XML/LDAP remote phonebook
Smart dialing
Phonebook search/import/export
Call history: dialed/received/missed/forwarded
IP-PBX Features Busy Lamp Field (BLF), Bridged Line Apperance (BLA)
Anonymous call, anonymous call rejection
Hot-desking, voice mail
Flexible seating
Call park, call pickup
Executive and Assistant
Centralized call recording
Visual voice mail
Call recording
Display and Indicator 2.4" 320 x 240-pixel color display with backlight
16 bit depth color
LED for call and message waiting indication
Dual-color (red or green) illuminated LEDs for line status information
Wallpaper
Intuitive user interface with icons and soft keys
Multilingual user interface
Caller ID with name and number
Screensaver
Power saving
Feature keys 4 line keys with LED
4 line keys can be programmed up to 12 paper- less DSS keys (4-page view)
5 features keys: message, headset, redial, mute, hands-free speakerphone
6 navigation keys
Volume control keys
Interface Dual-port Gigabit Ethernet
Power over Ethernet (IEEE 802.3af), class 2
1 x RJ9 (4P4C) handset port
1 x RJ9 (4P4C) headset port
Other Physical Features Color: Classic Grey
Wall mountable
External Yealink AC adapter
AC 100~240V input and DC 5V/600mA output
Power consumption (PSU): 2-3W
Power consumption (PoE): 3.5-5W
Dimension (W*D*H*T):
212mm*186mm*146mm*42mm
Operating humidity: 10~95%
Operating temperature: -10~50°C (+14~122°F)
Management Configuration: browser/phone/auto-provision
Auto provision via FTP/TFTP/HTTP/HTTPS for mass deploy
Auto-provision with PnP
Zero-sp-touch, TR-069
Phone lock for personal privacy protection
Reset to factory, reboot
Package tracing export, system log
Network and Security SIP v1 (RFC2543), v2 (RFC3261)
Call server redundancy supported
NAT traversal: STUN mode
Proxy mode and peer-to-peer SIP link mode
IP assignment: static/DHCP
HTTP/HTTPS web server
Time and date synchronization using SNTP
UDP/TCP/DNS-SRV (RFC 3263)
QoS: 802.1p/Q tagging (VLAN), Layer 3 ToS DSCP
SRTP for voice
Transport Layer Security (TLS)
HTTPS certificate manager
AES encryption for configuration file
Digest authentication
OpenVPN, IEEE802.1X
IPv6
LLDP/CDP/DHCP VLAN
ICE
Package Features Package content:
- Yealink SIP-T33G IP phone
- Handset with handset cord
- Ethernet Cable (1.5m CAT5E UTP Cable)
- Stand
- Quick Start Guide
- Power Adapter (Optional)
Qty/CTN: 10 PCS
N.W/CTN: 9.56 kg
G.W/CTN: 10.52 kg
Giftbox size: 238 mm*210 mm*103 mm
Carton Meas: 535 mm*443 mm*250 mm
Compliance REACH




WebAfrica Internet



The best price and guaranteed service and backup from official computer suppliers in South Africa for the SIP-T33G Yealink SIP-T33G Gigabit Colour screen Desktop IP phone.

Available from this online computer store delivering door-to-door in Johannesburg, Cape Town, Port Elizabeth, Pretoria, Pietermaritzburg, Polokwane, Durban and all over South Africa.

Find related SIP-T33G Yealink SIP-T33G Gigabit Colour screen Desktop IP phone products in our VoIP handsets phones Category for even more options. Read reviews and find out about SIP-T33G Yealink SIP-T33G Gigabit Colour screen Desktop IP phone. Discounts, specials and cheap prices only at ComX Computers.




 
SIP-T33G laptops South AfricaSIP-T33G Notebooks South AfricacomputersSIP-T33G notebook sales in South Africa
Home | Contact Us | Privacy Policy | Shop by Brand | Shop by Category
CGSO
ComX Computers is a South African online store since 2002. All transactions are subject to our terms of sale.